Credit/Debit card payment problem
Incident Report for Switch
Resolved
We are pleased to confirm that the issue affecting credit / debit card payments made via the SwitchINS Portal has now been resolved. Please accept our apologies for any inconvenience caused.
Posted about 1 year ago. Jul 20, 2018 - 17:08 WEST
Investigating
We're aware of issues making payments via the SwitchINS portal and engineers are working to make payments possible again. Please accept our apologies for any inconvenience caused.
Posted about 1 year ago. Jul 20, 2018 - 15:23 WEST
This incident affected: SwitchINS Portal.